02142231000

فعال سازی CME بر روی مسیریاب های (Router) سیسکو با استفاده از CLI

  • توسط : بهادر نیاکان
  • در تاریخ : ۲۱ اردیبهشت ۹۸

با استفاده از کابل کنسول، Telnet یا  SSH  (در صورتی که قبلا بر روی روتر پیکربندی مورد نیاز ایجاد شده) به مسیریاب متصل شوید.

با استفاده از دستورات زیر بر روی اینترفیس های روتر پیکربندی های مورد نظر را ایجاد نمایید.

AVIJEHFAVA(config)#interface fast0/0
AVIJEHFAVA(config-if)#ip address 192.168.1.254 255.255.255.0
AVIJEHFAVA(config-if)#no shutdown
AVIJEHFAVA(config-if)#exit
AVIJEHFAVA(config)#interface loopback0
AVIJEHFAVA(config-if)#ip address 192.168.2.254 255.255.255.255
AVIJEHFAVA(config-if)#exit

نام کاربری و رمز ورود را ایجاد کنید.

AVIJEHFAVA(config)# username admin privilege 15 password admin
AVIJEHFAVA(config)#enable secret admin
AVIJEHFAVA(config)#ip http server
AVIJEHFAVA(config)#ip http secure-server
AVIJEHFAVA(config)#ip http authentication local

دستورات زیر پیکربندی لازم را جهت تبدیل مسیریاب به یک سرویس دهنده ntp انجام میدهد. پس از ایجاد این پیکربندی مسیریاب ساعت و تاریخ را برای تلفن ها ارسال میکند تا بر روی مانیتور نمایش داده شود.

AVIJEHFAVA(config)#ntp server 192.168.1.100
AVIJEHFAVA(config)# clock timezone Tehran 3 30
AVIJEHFAVA(config)#!

با دستورات زیر بر روی مسیریاب پیکربندی های مورد نیاز جهت تبدیل مسیریاب به یک DHCP  سرور رای ایجاد نمایید.

AVIJEHFAVA(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.100
AVIJEHFAVA(config)#ip dhcp excluded-address 192.168.1.254
AVIJEHFAVA(config)#ip dhcp pool CCNA_COLLABORATION
AVIJEHFAVA(dhcp-config)# network 192.168.1.0 255.255.255.0
AVIJEHFAVA(dhcp-config)# default-router 192.168.1.254
AVIJEHFAVA(dhcp-config)# dns-server 192.168.1.10 192.168.1.20
AVIJEHFAVA(dhcp-config)# option 150 ip 192.168.2.254
AVIJEHFAVA(dhcp-config)# domain-name avijehfava.ir

هم اکنون پیش نیاز های لازم جهت فعال سازی cme بر روی مسیریاب انجام شده است. دستورات زیر را وارد نمایید تا CME فعال گردد.

AVIJEHFAVA(config)#telephony-service
AVIJEHFAVA(config-telephony)#max-dn 10
AVIJEHFAVA(config-telephony)#max-ephone 10
AVIJEHFAVA(config-telephony)#ip source address 192.168.2.254 port 2000
AVIJEHFAVA(config-telephony)#system message Avijeh Fava
AVIJEHFAVA(config-telephony)#create cnf-files
AVIJEHFAVA(config-telephony)#exit

حال بایستی تلفن های آی پی و شماره تلفن های مربوط به آن ها را ایجاد کنید. بنابراین دستورات زیر را وارد کنید. دستورات زیر دو شماره تلفن جدید ایجاد میکند تا بعدا بتوان آن را به یک تلفن آی پی اختصاص داد.

AVIJEHFAVA(config))# ephone-dn 1 dual-line
AVIJEHFAVA(config-ephone-dn))#number 100
AVIJEHFAVA(config-ephone-dn))# description Management,(100)
AVIJEHFAVA(config-ephone-dn))#label Management,(100)
AVIJEHFAVA(config-ephone-dn))#name Management
AVIJEHFAVA(config-ephone-dn))#exit
AVIJEHFAVA(config)#!
AVIJEHFAVA(config-ephone-dn)# ephone-dn 2 dual-line
AVIJEHFAVA(config-ephone-dn)#number 101
AVIJEHFAVA(config-ephone-dn)# description Sales,(101)
AVIJEHFAVA(config-ephone-dn)#label Sales,(101)
AVIJEHFAVA(config-ephone-dn)#name Sales
AVIJEHFAVA(config)#exit
AVIJEHFAVA(config)#!

دستورات زیر یک تلفن آی پی ۷۹۱۱  با آدرس مک ۰۰۰B.465C.CD46 و  یک سافت فون با مک آدرس mac-address 452B.248B.CF78 را ایجاد میکند و شماره تلفن های ایجاد شده در مرحله قبل را به آن ها اختصاص میدهد.

AVIJEHFAVA(config)#ephone 1
AVIJEHFAVA(config-ephone)# description Management,(100)
AVIJEHFAVA(config-ephone)# mac-address 000B.465C.CD46
AVIJEHFAVA(config-ephone)#type 7911
AVIJEHFAVA(config-ephone)#button 1:1
AVIJEHFAVA(config-ephone)#reset
AVIJEHFAVA(config-ephone)#restart
AVIJEHFAVA(config-ephone)#exit
AVIJEHFAVA(config)#!
AVIJEHFAVA(config)#ephone 2
AVIJEHFAVA(config-ephone)# description Sales,(101)
AVIJEHFAVA(config-ephone)# mac-address 452B.248B.CF78
AVIJEHFAVA(config-ephone)#type CIPC
AVIJEHFAVA(config-ephone)#button 2:1
AVIJEHFAVA(config-ephone)#reset
AVIJEHFAVA(config-ephone)#restart
AVIJEHFAVA(config-ephone)#exit